0
\$\begingroup\$

This page (and apparently only this page, but I'm not sure why) has a JavaScript error:

Uncaught TypeError: Cannot read property '0' of undefined

I'm seeing this in the JavaScript Console Chrome 11.0.696.28 beta in OSX. It is of course stopping all JavaScript on the page, preventing me from commenting or doing anything.

\$\endgroup\$
1
  • \$\begingroup\$ Huh. A couple other sites are actually claiming this same issue. Thus far it's been seen on Super User, Gaming, and Skeptics - each only on a single page. \$\endgroup\$
    – Grace Note StaffMod
    Apr 4 '11 at 13:30
2
\$\begingroup\$

This was examined and resolved by balpha. I'll quote his answer here:

This is fixed now.

It took a whole lot of single-stepping through callback after callback after callback, but in the end, it was actually a bug in the HTML code.

When you link directly to an answer (instead of just a question), this answer is shown in a highlight color which then fades back to normal (as everybody has probably seen).

We're in the process of converting our pages from the old ASPX view engine to Razor, and in the process of converting the partial view that shows a single answer (this conversion happened today), there was a little too much encoding happening, so the result for the highlighted answer looked like this:

<div id="answer-85877" class="answer" style=&quot;background-color:#F6F5EE;&quot;>

This is obviously anything but valid (but it actually depends on the browser how it gets handled). When the jQuery color animation plugin tried to find the current color, all it found was either garbage or nothing (depending on the browser). When it found nothing, this worked fine (except that you didn't see the animation); when it found garbage, this caused the code to throw up.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .